composer 安裝擴展包時(shí)忽略版本匹配

Composer

執行 composer install 安裝擴展包時(shí)遇到錯誤: Your requirements could not be resolved to an installable set of packages。這是因為當前PHP版本不匹配composer.json要求的版本,使用 --ignore-platform-reqs 參數可以忽略版本匹配

辰風(fēng)沐陽(yáng) 閱讀 1039 2021-10-31

composer install、update、require 區別

php Composer

當本地存在 `composer.lock` 文件時(shí), composer install 將會(huì )去讀取 composer.lock 中存儲的版本號, 并且以此標準去下載依賴(lài); 而 composer update 則不會(huì )去讀取 composer.lock 中的版本號, 他仍然會(huì )去讀取 composer.json 中定義的依賴(lài), 生成新的 composer.lock 文件

辰風(fēng)沐陽(yáng) 閱讀 1549 2021-06-03

composer search 搜索 packagist.org 依賴(lài)包

Composer

composer search 搜索 packagist.org 依賴(lài)包。應用場(chǎng)景:在TP框架中想引入TP官方的依賴(lài)包,忘記了包名或不想手打,可以先使用 search 命令搜索出來(lái), 再將需要的依賴(lài)包復制到命令行中安裝

辰風(fēng)沐陽(yáng) 閱讀 1040 2021-05-17

phpoffice/phpexcel 讀取 Excel 表格數據

php Composer

PHP版本7.2以下推薦使用 phpoffice/phpexcel 讀取表格數據

辰風(fēng)沐陽(yáng) 閱讀 1655 2021-04-06

nesbot/carbon 日期時(shí)間處理擴展包

php Composer

應用場(chǎng)景: 根據時(shí)間戳出計算到現在的時(shí)間: 剛剛, 1分鐘前

辰風(fēng)沐陽(yáng) 閱讀 1389 2021-04-04

phpoffice/phpexcel 導出 Excel 表格數據

php Composer

導出Excel表格適用場(chǎng)景: 導出訂單,導出用戶(hù)信息; PHP7.2版本以下推薦使用 phpoffice/phpexcel(TP5.0,TP5.1),PHP7.2版本以上推薦使用 phpoffice/phpspreadsheet(TP6.0),phpoffice/phpexcel 已經(jīng)停止維護

辰風(fēng)沐陽(yáng) 閱讀 2049 2021-04-04

Composer 常用擴展包匯總

Composer

本文記錄一些好用的composer包,找到好的擴展包,開(kāi)發(fā)中能夠大大提高開(kāi)發(fā)效率。相信本文一定有你需要的擴展包

辰風(fēng)沐陽(yáng) 閱讀 2221 2021-01-02

Composer 使用縮略名調用命令

Composer

縮略名調用命令的前提:這個(gè)縮略名具有唯一性,不會(huì )混淆;否則會(huì )報錯,示例:`composer in` Command "in" is ambiguous (init, install and 1 more).【命令“in”不明確(init、install和1個(gè)以上)】

辰風(fēng)沐陽(yáng) 閱讀 1296 2020-10-10

composer remove 移除擴展包

Composer

remove 命令用于移除 composer.json 中的擴展包;也可以一次移除多個(gè)包:composer remove 擴展包1 擴展包2 擴展包3

辰風(fēng)沐陽(yáng) 閱讀 1345 2020-09-17

composr require 下載擴展包

Composer

composr require 將依賴(lài)添加或更新到 composer.json 文件中,不存在則自動(dòng)創(chuàng )建;支持一次引入多個(gè)composer包,使用空格隔開(kāi)就行;修改已下載的包的版本,直接引入即可,會(huì )自動(dòng)以刪除前安裝的,改為最新指定的版本

辰風(fēng)沐陽(yáng) 閱讀 1286 2020-09-17